
Introduction to Teacher's Aide

What is Teacher's Aide
Teacher's Aide is a full-featured grade management program for the Macintosh 
computer.

Uses of Teacher's Aide
Teacher's Aide replaces your paper gradebook.    Teacher's Aide performs the 
same functions that a gradebook does, but it calculates grades automatically, it is
easy to modify, and it prints many kinds of reports on command.

No particular grade level or class size is required to use Teacher's Aide.    It can 
manage the grades of a kindergarten class or a university class, from a handful 
of students to several hundred.

Compatibility
You can run Teacher's Aide on any Macintosh with System software 6.0.4 or later.
Teacher's Aide is fully compatible with System 7.

Tutorial—Making a Class

When you have completed this tutorial, you will have made a new class and will 
be ready to make your own.    In this tutorial you will create a class, enter 
students and grades, and print reports.    If you are not familiar with standard 
Macintosh terms such as double-clicking, selecting and dragging, consult the 
owner's guide that came with your computer before starting this tutorial.

Starting Teacher's Aide
1.    Start the computer with a start-up disk.
2.    Insert the Teacher's Aide disk.    
3.    If you are using a hard disk, drag the "Teacher's Aide" and "Sample 

Class" icons onto your hard drive's icon.
Warning:    Teacher's Aide is a copywrited program.    You may make 

copies of the program only for your own exclusive use.    See the 
licensing agreement for more information.

4.    Double-click the Teacher's Aide icon to start the program.

Creating the class
1.    Choose New from the File menu.    A dialog box will appear.
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Fig. 1.    The New Class dialog box

2.    Next to Name, type "Beatles 101".
3.    Click on "Music" to make this a music class.    (These designations are

used only to assign an icon to the class.)
4.    Press the tab key to move the cursor next to Teacher.    Type 

"Professor Martin".
Note: You may use the tab key at any time to move among text fields.
5.    Click on the OK button to make the new class.

The class window will now appear.

Fig. 2. The class window

The class window shows the information you just entered on the top and two 
empty lists on the bottom.

Entering students
1.    Choose New from the Students menu.    A dialog box will appear.

Teacher's Aide 2



Fig. 3.    The New Student dialog box

2.    Next to Last Name, type "Lennon".    Press tab to move to the next 
field.

Note: Names are stored to 15 characters.    You can type more than that, 
but extra characters are ignored.

3.    Next to First Name, type "John".
4.    Next to ID Number, type "123-Imagine".
Note: ID numbers are optional.    They can be used when printing in the 

place of names to keep grades private.    You may store any 
information you would like in ID Number.

5.    Now that all information about this student has been given, press 
return or click "Add Another" to enter him into the class.

6.    Enter these students exactly the way you did the first one, using the 
tab key to move between text fields and return when you are finished 
with a student.

Last Name First Name ID Number
Harrison George DarkHorse-43
McCartney Paul 1940-1965
Best Pete 62 Loser

7.    Enter the last student, but instead of pressing return when you are 
done, click the Finished button instead.

Last Name First Name ID Number
Starkey Richard 0000456

The class window will now list the new students.    Notice that students are listed 
alphabetically, even though you did not enter them in alphabetical order.

Editing students
1.    Select student Richard Starkey by clicking on his name.
2.    Choose Edit from the Students menu.
3.    Next to Last Name, type "Starr".
4.    Next to First name, type "Ringo".
5.    Click OK to save this change.
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Deleting students
1.    Select student Pete Best.
2.    Choose Delete from the Students menu.
3.    When you are asked if you really want to do this, click Yes.    Pete Best

is now removed from the class.

Entering a grade
1.    Choose New from the Grades menu.    A dialog box will appear.

Fig. 4.    The New Grade dialog box

2.    Next to Grade Name, type "Let It Be".
3.    Next to Max Points, type "50".
4.    Next to Month, type "6", next to Day type"9", and next to Year, "70".    

For now you may ignore the Set, Compact Grade and Weighted 
buttons.

5.    Click OK to enter this grade into the class.
Note: Grades are automatically ordered chronologically.

Opening a grade
When you enter a new grade, the grade window is automatically opened.    At 
other times you can open a grade by double-clicking on it.
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Fig. 5.    The grade window

On the top of the window you see information about the grade, and on the bottom
of the window you see the names of the students in the class with their points for 
the grade.

1.    Click Change All Points.    A dialog box for George Harrison's points 
will appear.

Fig. 6.    The Points dialog box

2.    Next to Points, type "42".
3.    Press return to go to the next student.
4.    Enter these following points: John Lennon, 46; Paul McCartney, 47.    

Instead of a point value for student Ringo Starr, type the letter "E".    
Ringo Starr is now exempt from that grade, so this grade is not 
included in calculating his average.    When you enter points for the last
student, the Points dialog box will go away.

The points you entered will now be displayed next to the students, and the 
grade's average will be updated.

Finding students
There are special ways to change points very quickly.

Teacher's Aide 5



1.    Type the letter "L".    Student John Lennon will automatically be 
selected.

2.    Press return.    This is the same as clicking the Change Points button.   
The Points dialog box will again appear.

3.    Type "49".
4.    Press return.    John Lennon's points are now changed.    Try finding 

the other students in the class by starting to type their last names.
5.    Click the go-away box to close this window.

Entering another grade
Enter this grade the same way you entered the first one, starting with choosing 
New from the Grades menu.

Name: Paperback Writer
Max Points: 20
Date: 5/8/66
Points: Harrison-19, Lennon-19, McCartney-20, Starr-19

Editing grades
1.    Select "Paperback Writer" in the grade list.
2.    Choose Edit from the Grades menu.
3.    Next to Name, type "Hey Jude".
4.    Click OK to save the change.    The grade that used to be "Paperback 

Writer" is called "Hey Jude".

Saving the class
1.    Choose Save from the File menu.    A dialog box will appear.

Fig. 7.    The Save dialog box
 
2.    Type "Beatles 101" under Save class as.
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3.    Click Save to store the class on disk.
Note:    It is very important to keep backups of you class files.    Make 

backups in the Finder by clicking on a file's icon and selecting 
Duplicate under the File menu.    Store backups on a different disk in a 
different location, if possible.

Deleting grades and reverting
1.    Select grade "Let It Be".
2.    Choose Delete from the Grade menu.
3.    When you are asked if you want to delete it or not, choose Yes. The 

grade "Let It Be" is now gone.
4.    Now choose Revert from the File menu.    Doing so will bring back the 

class as it was the last time you saved it.    In this case, the grade "Let 
It Be" will be restored.

5.    When you are asked if you want to discard changes, click Discard.    
Use Revert when you have changed or deleted something by mistake, 
and you wish to go back to the way the class was when you saved it 
last.

Opening students
1.    Select student Paul McCartney in the student list by clicking on him.
2.    Choose Open from the Students menu, or double click on Paul 

McCartney.    A window with information about this student will appear.

Fig. 8.    The student window

3.    Type the letter "L" to move to the grade "Let It Be".
4.    Press return to edit this grade.
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5.    Type "48".
6.    Press return.    The points are now changed.
7.    Click the go-away box to close the window.

Changing precision
1.    Choose Precision from the Options menu.    Here you choose how 

many digits you see every time you see an average or percent.
2.    Click on Nearest Hundredth.
3.    Click OK.    Every time you see an average or percent, it will be 

rounded to the nearest hundredth.

Displaying students
Sometimes it necessary to look at all of the students at once rather than look at 
them individually.    Use Display to do this.

1.    Choose Display All from the Students menu.    The Display dialog box 
will appear with all the students and their averages.

2.    Click OK.
3.    Choose Display Ranked from the Students menu.    The information for

each student is the same as before, but now the student are ordered 
by their averages, the best on top and worst on the bottom.

4.    Click OK.

Weighting grades
Right now, all of the grades are unweighted.    That means the relative effect each
grade has on a student's average is determined by its maximum points. That 
effect can be increased or decreased by assigning weights.

1.    Select "Hey Jude" in the grades list.
2.    Choose Edit from the Grades menu.
3.    Check the Weighted checkbox.    It is now possible to enter a weight.
4.    In the Weight text field, type "40".
5.    Click OK.

"Hey Jude" is now worth 40% of every student's average, and the remaining 
grades are used to finding the rest of the students' averages.    You may weight 
as many grades as you wish, as long as the total weight does not go over 100%.

Printing Reports
1.    Choose Print Students from the File menu.    The Print Students dialog

box will appear.
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Fig. 9.    The Print Students dialog box

2.    Select student George Harrison from the list.
3.    Hold the command key down, and click on student Paul McCartney.    

Now both are selected.
4.    Check the Use Message checkbox to indicate that you want to print a 

message on the student reports.
5.    In the Message text field, type "Hello goodbye".
6.    Click Student Reports to make the printout.
7.    In the printer dialog box, click OK.    Reports for George Harrison and 

Paul McCartney will be printed.

Where to go from here
You have completed the tutorial.    To learn more about Teacher's Aide's 
capabilities, including passwords, sets, and grade compaction, read the next 
section, Teacher's Aide Reference.
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Teacher's Aide Reference

The Reference section gives detailed information on each menu command and 
explains all the averaging methods available.

Averaging methods

Averages are normally determined by dividing total points by total possible 
points.    Teacher's Aide also lets you weight grades, add extra credit, give 
exemptions, use sets, and compact grades.

Weight
Normally, the relative effect each grade has on a student's average is determined
by its maximum points. That effect can be increased or decreased by assigning 
weights.    If a grade is weighted fifty percent, it is valued at half of each student's 
average, no matter how many points were possible for the grade.

A weight of zero is not the same as an unweighted grade.    Zero weight means 
that the grade is worth zero percent of a student's average, that is, it is not 
included at all when averaging grades.    You can use zero weight when you want
to ignore a particular grade for calculating averages.

Extra credit
To add extra credit points, create a grade with a maximum points value of zero.    
Whenever you see points for an extra credit grade, they will have the letters 
"E.C." next to them.    Extra credit grades may not be weighted.

Exemptions
To exempt a student from a grade, type the letter "E" in place of a point value.    
Grades labeled exempt will be ignored when a student's average is calculated.

Sets
A set is a group of related grades.    Use sets to weight grades as a group or to 
drop grades.

When a set is weighted, the members of that set together make up a certain 
percent of each student's average.    For instance, you can put all quizzes in a 
"Quiz" family and weight them 20%.    Grades may belong to only one set at a 
time and grades within a set may not be individually weighted.

Sets are also used to drop grades.    There can be up to three dropped grades in 
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a set.    For each student, Teacher's Aide determines the lowest percents for all of
the grades in the set and drops them.    Dropped grades have "(D)" next to them 
and are ignored when a student's average is calculated.    Drops are 
automatically updated when points change or when new grades are added to the
set.

To make a new set, select one of the unused sets under the Grades menu.    Give
your set a name, and give a weight or number of dropped grades if you want to.   
To put a grade into a set, click on the name of the set when you create the grade 
or when you edit it.

Compacting Grades
When you compact grades, all the grades disappear and students' averages are 
stored in a new grade as a number of points out of 1000.    It is useful to compact 
grades when a marking period is over and grades are final, and you don't want a 
lot of extra grades cluttering up the class.

A compacted grade is just like any other.    You may assign it to a set, or change 
points in it, or weight it.    Give a compacted grade a weight of zero if you don't 
want it to be counted in current averaging.

Compacting is not reversible.    There is no way to expand a compacted grade 
into the grades that it was made from other than by doing so immediately by 
choosing Revert from the File menu.    If it is possible that points in the 
compacted grade will have to be changed, keep a backup of the class.

When grades are compacted, existing compacted grades will not be re-
compacted or used in determining the new grade.    That is, if you have a 
compacted grade called "First Quarter", when you make a "Second Quarter" 
segment the "First Quarter" grade will remain in the class and not be used when 
determining the "Second Quarter" grade.    You can decide whether or not a 
grade will be compacted or not by clicking on Compacted Grade when you edit a 
grade.

Menu Commands

The File Menu
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New
Make a new class.    Only one class may be open at one time.    Class name and 
teacher name are printed on all printed reports, so be sure to fill them in.    Class 
type is used only to assign an icon to the class.

Open
Open a class stored on disk.    If a class is already open, you must close it before 
opening another class.    If you are unfamiliar with opening files, see your 
Macintosh owner's manual.

Close
Close the current class.    If you have made changes to a class you will be asked 
whether you want to save them before closing.

Save
Save a class to disk.    If you have not given the current class a name, you will be 
asked to do so before saving the class. 

Save As
Saves a class to disk with a new name.    By saving the class with a different 
name than what is currently being used, you create a new copy of the class file.

Revert
Goes back to the class as it was the last time you saved it.    If you have made a 
mistake while working with your class, use Revert to return to the class as it was 
the last time you saved it.

Import Names
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Use Import Names when you have a list of students in a spreadsheet or word 
processing document that you would like to enter into the class.    ID Numbers 
are optional when importing names.

Important:    You must save your spreadsheet document or word processing 
document in Text format before importing names into Teacher's Aide.

If you are importing names from a spreadsheet, they must be in this format:
First Column                Second Column                Third Column  

Row 1 Last Name 1 First Name 1 ID Number 1
Row 2 Last Name 2 First Name 2 ID Number 2

If you are importing names from a word processing document, they must be in 
this format: 
Last Name 1 <tab> First Name 1 <tab> ID Number 1 <return>
Last Name 2 <tab> First Name 2 <tab> ID Number 2 <return>

Export Text
Use Export Text when you want a complete record of the class in a format 
readable by any spreadsheet or word processor.    The information exported is 
student names, grade names, points, and averages.

Page Setup
Specifies page size, orientation and special effects for printing.    This command 
performs no printing, but sets things up for when you do print.    The options for 
setting up a page depends on the type of printer you are using.

Print Students
Prints specified student reports or list of students.    Print Students can print the 
following:

Student Report

Student Report prints a complete report for a student.    Use it to give students all 
of their points and their average.

Student reports can have one line messages that are printed under the student's 
name.    If you want to give students messages on student reports, check Use 
Message and type what you want students to see next to Message.
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Click on a student to select him for printing.    Drag over many students to select 
more than one.    When the shift key is down, clicking on a student will select 
everyone between the student you click on and the previously selected student.   
When the command key is down, clicking on a student will select or de-select 
him.    When you have selected every student for which you want a report, click 
the Student Reports button.

Student List

Use Student List to print a roster for the class.

Student List With Averages

Student List With Averages By ID

Use Student List With Averages By ID when you wish to keep grades private by 
not printing names along with the averages.    To print a Student List With 
Averages by ID, check the ID Only checkbox first before clicking on the Student 
List With Averages button.

Print Grades
Prints specified grade reports or lists of grades.    Print Grades can print the 
following:

Grade Report

Use the grade report to give students their points when you do not wish to hand 
back the test or assignment, or when you want a printed report on all students' 
performance on a grade.

Click on a grade to select it for printing.    Drag over many grades to select them.  
When the shift key is down, clicking on a grade will select each grade between 
the grade you click on and the previously selected grade.    When the command 
key is down, clicking on a grade will select or de-select it.    When you have 
selected all the grades for which you want reports, click the Grade Reports 
button.
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Grade Report By ID

Use Grade Report By ID in the same circumstances as you would a Grade 
Report, but when you wish to keep grade private by not printing names along 
with the averages.    Check the ID Only checkbox before clicking Print Reports to 
print a Grade Report By ID.

Grade List

Grade List With Averages

Print All

Use Print All when you want a report of all the information about a class.    Print 
All gives students, grades, points, and averages.    Print all often uses less paper 
if you choose landscape orientation in the Page Setup dialog before printing.

Print All by ID

Use Print All by ID when you wish to keep grades private by not printing names.   
Check the ID Only checkbox before clicking Print All to Print All by ID.

Quit
Quit exits Teacher's Aide.    If a class is open, you must close it before quitting.

The Edit menu

Teacher's Aide does not use this menu.    It is used in conjunction with desk 
accessories only.

The Students menu
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New
Enter new students.    First names, last names and ID numbers are stored to 15 
characters.    ID numbers are optional.    ID numbers can also be used to store 
whatever information you want on that student, such as year in school.

Press return or click Add Another when you have typed all of a student's 
information to enter that student and go on to the next.    Students are 
automatically ordered alphabetically in the student list.    Click Finished when you 
have entered the information for the last student.

Open
Open the currently selected student in the Students list.    Change points by 
selecting a grade from the list and clicking Change Points.    You can also change
points by double-clicking on a grade or pressing return when it is selected.    The 
Change All Points button lets you change all of the points from the currently 
selected grade to the last grade.

Use the arrow keys to move up or down in the list.    Teacher's Aide will find 
grades for you.    To select a grade, begin typing it.    You will automatically go to 
that name and it will be selected.    To select "Paper" type the letter "p".    If there 
is also a "Presentation" in the class, type "pr" to select that grade.

Edit
Change information of student currently selected student.    Use Edit to correct or 
change information you entered in the New Student dialog box.

Delete
Remove the currently selected student from the class.

Display All
Show all students along with their averages.

Display Ranked.
Show all students ranked by average highest to lowest.

Teacher's Aide 16



The Grades menu

New
Enter new grade.    Grade names are stored to 30 characters.    Maximum Points 
can range from zero (extra credit) to 1000.    The date defaults to the present date
but may be changed to reflect the actual day the grade was given.    A set for the 
grade can be selected from the list of sets (that you must define—see "Sets" 
above).    You will rarely use the Compacted Grade checkbox (see "Compacting 
Grades" above).    Weight is assigned by checking the weight checkbox and 
typing a weight (see "Weight" above).    Grades are automatically stored 
chronologically in the grades list.    

Normally all student's points for a new grade are zero.    By holding down the 
option key while clicking OK, the students will instead be all exempt.    By holding 
down the command key, the points will all be the maximum points possible for 
the grade.    When you click OK, the grade will be opened so that you can 
immediately enter or change points.

Open
Open the currently selected grade.    Change points by selecting a student from 
the list and clicking Change Points.    You can also change points by double-
clicking on a student or pressing return when a student is selected.    Change All 
Points lets you change all of the points from the currently selected student to the 
last student.

Use the arrow keys to move up or down in the list.    Teacher's Aide will find 
students for you.    To select a student, begin typing his name.    You will 
automatically go to that name and it will be selected.    To select "Smith" type the 
letter "s".    If there is also a "Smyth" in the class, type "smy" to select that 
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student.

To add a point to every student's grade, hold the command key and press "]" 
(right bracket).    To subtract a point from every student's grade, hold the 
command key and press "[" (left bracket).

Edit
Change information of currently selected grade.    Use Edit to correct or change 
information you entered in the New Grade dialog box.

Delete
Remove currently selected grade from the class.

Delete All
Remove all grades from the class.

Compact Grades
Remove grades from the class and stores student averages in one new grade.    
Warning:    Compacting is not reversible. Use Compact Grades with care.    See 
"Compacting Grades" above.

Display All
Show all grades with along with averages.

Display Ranked
Show all grades ranked by average highest to lowest.

Sets
Change information about a set.    Use the set dialog to change a set name, 
weight, or number of dropped grades.    See "Sets" above.    It is up to you to 
decide on names and weights for sets.

The Options menu
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Change Points
Set point value for selected student and grade.    Select a student and a grade 
from the lists in the class window and choose Change Points to make the 
change.

Password
Password protect the class.    Passwords are used to restrict access to a class.    
If a class has a password, the password is required to open it.

When you enter a password, you will be asked to verify it to make sure you typed
it correctly.    If you do not wish to password protect a class, click Don't Use a 
Password.    Passwords are saved along with the rest of the class.    If you do not 
save a class after giving it a password, it will not be password protected.

Important:    Because passwords are easily forgotten, use them only when 
necessary.    If possible, make a unprotected backup copy of the class on another
disk and store that disk in a safe place.    Passwords are an effective means of 
protecting classes, but a determined computer expert may be able to get around 
them.

Cutoffs
Enter letter-determining cutoffs.    For each letter, enter the lowest possible 
percent required to receive it.    If you don't want to use a letter designation, set 
the cutoff for that letter to the same number as the one before it.    For example, if
you never want to give an A-, set both A and A- to 90.

Use Round Up to decide if averages can be rounded up for the purpose of letter 
assignment.    This option has nothing to do with rounding of the numbers you 
see, but only with what letters are assigned .

Precision
Change number of digits used for averages and percents.    Precision will change
the number of digits you see every time you see an average or percent. 

This option has no effect on the accuracy Teacher's Aide uses when determining 
percents; it only determines to how many decimal places you will see the results.

Edit Class Info
Change class information.    Use Edit Class Info to change information you 
entered in the New Class dialog.
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